Перезаполнение ставки НДС

Публикация № 1661063 18.05.22

Пользовательские инструменты - Обработка документов

Обработка НДС заполнение Справочник Перечисление СтавкаНДС УдалитьСтавкаНДС Комплексная автоматизация

Обработка умеет перезаполнять ставку НДС в табличных частях документов. На странице "Заказы клиентов" можно вывести список заказов с незаполненным НДС и перезаполнить. На Странице "Общее заполнение", выводится список всех документов и табличных частей с типом реквизита "СправочникСсылка.СтавкиНДС", здесь также можно перезаполнить ставку НДС.

После не совсем удачного перехода с КА 2.4 на КА 2.5 было обнаружено, что у некоторых документов в табличных частях не заполнена Ставка НДС.

В КА 2.4 реквизит Ставка НДС это перечисление, а в КА 2.5 это уже справочник, реквизит с типом перечисление был переименован в "УдалитьСтавкаНДС", и добавлен реквизит "СтавкаНДС" с типом справочник.

 

Страница "Заказы клиентов":

По кнопке "найти заказы клиентов с пустым НДС", показывает проведенные заказы, у которых реквизит ставка НДС не заполнен с налогообложением: ПродажаОблагаетсяНДС и ПродажаНаЭкспорт.

По кнопке "Заполнить НДС В заказах Клиентов" в отмеченных заказах проставляется НДС через обработку табличных частей из общего модуля.

Можно указать количество обрабатываемых документов, которые будут обработаны.

 

Страница "Общее заполнение":

При открытии формы на странице заполняется список документов, у которых есть реквизит с типом "СправочникСсылка.СтавкиНДС" и реквизит "СуммаНДС" в табличной части.

По нажатии кнопки "Найти документы с пустым НДС" показывает количество документов с незаполненной ставкой НДС и реквизитом Сумма НДС > 0.

По нажатию кнопки "Заполнить НДС" заполняет НДС в отмеченных документах.

При заполнении нужно выбрать источник заполнения: Справочник "Номенклатура", Реквизит "УдалитьСтавкаНДС" или фиксированное значение.

 

Исходный код:


&НаСервере
Процедура НайтиДокументыСПустымНДСНаСервере()
	
	Для Каждого СтрТаблицы Из Объект.ОбрабатываемыеДокументы Цикл
		
		Запрос = Новый Запрос;
		Запрос.Текст = 
		"ВЫБРАТЬ РАЗЛИЧНЫЕ
		|	Документ.Ссылка КАК Ссылка
		|ИЗ
		|	[Таблица] КАК Документ
		|ГДЕ
		|	(Документ.СтавкаНДС = ЗНАЧЕНИЕ(Справочник.СтавкиНДС.ПустаяСсылка) ИЛИ Документ.СтавкаНДС = НЕОПРЕДЕЛЕНО)
		|	И Документ.СуммаНДС > 0
		|	И Документ.Ссылка.Проведен";		
		Запрос.Текст = СтрЗаменить(Запрос.Текст, "[Таблица]", "Документ." + СтрТаблицы.Документ + "." + СтрТаблицы.ТабличнаяЧасть); 		
		СтрТаблицы.Найдено = Запрос.Выполнить().Выбрать().Количество();
		СтрТаблицы.Пометка = ?(СтрТаблицы.Найдено > 0, Истина, Ложь);
		
	КонецЦикла;
	
КонецПроцедуры

&НаКлиенте
Процедура НайтиДокументыСПустымНДС(Команда)
	
	НайтиДокументыСПустымНДСНаСервере();
	
КонецПроцедуры

&НаСервере
Процедура ПриОткрытииНаСервере()
	
	Для Каждого ДокументИмя Из Метаданные.Документы Цикл
		Для Каждого ТабличнаяЧастьИмя Из ДокументИмя.ТабличныеЧасти Цикл
			Для Каждого РеквизитИмя Из ТабличнаяЧастьИмя.Реквизиты Цикл
				Если РеквизитИмя.Тип = Новый ОписаниеТипов("СправочникСсылка.СтавкиНДС") И ТабличнаяЧастьИмя.Реквизиты.Найти("СуммаНДС") <> Неопределено Тогда
					НовыйДокумент = Объект.ОбрабатываемыеДокументы.Добавить();
					НовыйДокумент.Документ = ДокументИмя.Имя;
					НовыйДокумент.ТабличнаяЧасть = ТабличнаяЧастьИмя.Имя;					
				КонецЕсли;				
			КонецЦикла;
		КонецЦикла;		
	КонецЦикла;
	
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	
	ПриОткрытииНаСервере();
	
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьНДСНаСервере()
	
	Для Каждого СтрТаблицы Из Объект.ОбрабатываемыеДокументы Цикл
		
		Если СтрТаблицы.Пометка Тогда
			
			Запрос = Новый Запрос;
			Запрос.Текст = 
			"ВЫБРАТЬ РАЗЛИЧНЫЕ
			|	Документ.Ссылка КАК Ссылка
			|ИЗ
			|	[Таблица] КАК Документ
			|ГДЕ
			|	(Документ.СтавкаНДС = ЗНАЧЕНИЕ(Справочник.СтавкиНДС.ПустаяСсылка) ИЛИ Документ.СтавкаНДС = НЕОПРЕДЕЛЕНО)
			|	И Документ.СуммаНДС > 0
			|	И Документ.Ссылка.Проведен";		
			Запрос.Текст = СтрЗаменить(Запрос.Текст, "[Таблица]", "Документ." + СтрТаблицы.Документ + "." + СтрТаблицы.ТабличнаяЧасть); 		
			Выборка = Запрос.Выполнить().Выбрать();
			
			Пока Выборка.Следующий() Цикл			
				ДокументОбъект = Выборка.Ссылка.ПолучитьОбъект();
				
				Для Каждого Стр Из ДокументОбъект[СтрТаблицы.ТабличнаяЧасть] Цикл 					
					Если Метаданные.Документы[СтрТаблицы.Документ].ТабличныеЧасти[СтрТаблицы.ТабличнаяЧасть].Реквизиты.Найти("СтавкаНДС") = Неопределено Тогда							
						Продолжить;
					ИначеЕсли Объект.БратьНДСИз = "НДСДляПодстановки" Тогда 						
						Стр.СтавкаНДС = Объект.СтавкаНДС;																	
					ИначеЕсли Объект.БратьНДСИз = "СправочникаНоменклатура" Тогда 
						Если Метаданные.Документы[СтрТаблицы.Документ].ТабличныеЧасти[СтрТаблицы.ТабличнаяЧасть].Реквизиты.Найти("Номенклатура") = Неопределено Тогда
							Сообщить("В табличной части: " + СтрТаблицы.ТабличнаяЧасть + " документа: " + СтрТаблицы.Документ + " не используется реквизит номенклатура!");	
							Продолжить;
						КонецЕсли;
						
						Стр.СтавкаНДС = Стр.Номенклатура.СтавкаНДС;											
					ИначеЕсли Объект.БратьНДСИз = "ПеречислениеУдалитьСтавкаНДС" Тогда
						Если Метаданные.Документы[СтрТаблицы.Документ].ТабличныеЧасти[СтрТаблицы.ТабличнаяЧасть].Реквизиты.Найти("УдалитьСтавкаНДС") = Неопределено Тогда
							Сообщить("В табличной части: " + СтрТаблицы.ТабличнаяЧасть + " документа: " + СтрТаблицы.Документ + " не используется реквизит УдалитьСтавкаНДС!");	
							Продолжить;	
						КонецЕсли;
						
						СправочникСтавкаНДС = Справочники.СтавкиНДС.НайтиПоРеквизиту("ПеречислениеСтавкаНДС", Стр.УдалитьСтавкаНДС);						
						Если ЗначениеЗаполнено(СправочникСтавкаНДС) Тогда 						
							Стр.СтавкаНДС = СправочникСтавкаНДС;
						КонецЕсли;						
					КонецЕсли;					
				КонецЦикла;
				Попытка
					ДокументОбъект.Записать(РежимЗаписиДокумента.Проведение, РежимПроведенияДокумента.Неоперативный);
				Исключение
					Сообщить(ОписаниеОшибки());	
				КонецПопытки;				
			КонецЦикла;
			
		КонецЕсли;
		
	КонецЦикла;
	
КонецПроцедуры

&НаКлиенте
Процедура ЗаполнитьНДС(Команда)
	
	Если ЗначениеЗаполнено(Объект.БратьНДСИз) Или ЗначениеЗаполнено(Объект.СтавкаНДС) Тогда 
		ЗаполнитьНДСНаСервере();
	Иначе 
		Сообщить("Необходимо выбрать источник заполнения НДС или фиксированную ставку!");
	КонецЕсли;
	
КонецПроцедуры

//-----------------Заказы клиентов------------------//

&НаСервере
Процедура ЗаполнитьНДСВзаказахКлиентовНаСервере()
	
	Для Каждого СтрТаблицы Из Объект.ДокументыЗаказыКлиентов Цикл
		
		Если СтрТаблицы.Пометка Тогда
			
			ДокументОбъект = СтрТаблицы.Документ.ПолучитьОбъект();
			
			СтруктураПересчетаСуммы = ОбработкаТабличнойЧастиКлиентСервер.ПараметрыПересчетаСуммыНДСВТЧ(ДокументОбъект);
			
			СтруктураДействий = Новый Структура;
			//СтруктураДействий.Вставить("ЗаполнитьПризнакТипНоменклатуры", Новый Структура("Номенклатура", "ТипНоменклатуры"));
			//СтруктураДействий.Вставить("ЗаполнитьПризнакАртикул", Новый Структура("Номенклатура", "Артикул"));
			СтруктураДействий.Вставить("ЗаполнитьСтавкуНДС", Новый Структура("НалогообложениеНДС, Дата, ПоДатеОтгрузки", ДокументОбъект.НалогообложениеНДС, ДокументОбъект.Дата, Истина));
			СтруктураДействий.Вставить("ЗаполнитьСтавкуНДСВозвратнойТары", ДокументОбъект.ВернутьМногооборотнуюТару);
			//СтруктураДействий.Вставить("ЗаполнитьПризнакБезВозвратнойТары", ДокументОбъект.ВернутьМногооборотнуюТару);
			//СтруктураДействий.Вставить("ЗаполнитьПризнакОтмененоБезВозвратнойТары", ДокументОбъект.ВернутьМногооборотнуюТару);
			//СтруктураДействий.Вставить("ПересчитатьСуммуНДС", СтруктураПересчетаСуммы);
			//СтруктураДействий.Вставить("ПересчитатьСуммуСНДС", СтруктураПересчетаСуммы);
			ОбработкаТабличнойЧастиСервер.ОбработатьТЧ(ДокументОбъект.Товары, СтруктураДействий, Неопределено);
			
			Попытка
				ДокументОбъект.Записать(РежимЗаписиДокумента.Проведение, РежимПроведенияДокумента.Неоперативный);
			Исключение
				Сообщить(ОписаниеОшибки());	
			КонецПопытки;
			
		КонецЕсли;
		
	КонецЦикла;
	
КонецПроцедуры

&НаКлиенте
Процедура ЗаполнитьНДСВзаказахКлиентов(Команда)
	
	ЗаполнитьНДСВзаказахКлиентовНаСервере();
	
КонецПроцедуры

&НаСервере
Процедура НайтиЗаказыКлиентовСПустымНДСНаСервере()
	
	Объект.ДокументыЗаказыКлиентов.Очистить();
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ РАЗЛИЧНЫЕ [ПЕРВЫЕ]
	|	Документ.Ссылка КАК Ссылка,
	|	Документ.Ссылка.Дата КАК Дата
	|ИЗ
	|	Документ.ЗаказКлиента.Товары КАК Документ
	|ГДЕ
	|	Документ.СтавкаНДС = ЗНАЧЕНИЕ(Справочник.СтавкиНДС.ПустаяСсылка)
	|	И Документ.Ссылка.Проведен
	|	И (Документ.Ссылка.НалогообложениеНДС = ЗНАЧЕНИЕ(Перечисление.ТипыНалогообложенияНДС.ПродажаОблагаетсяНДС)
	|			ИЛИ Документ.Ссылка.НалогообложениеНДС = ЗНАЧЕНИЕ(Перечисление.ТипыНалогообложенияНДС.ПродажаНаЭкспорт))
	|
	|УПОРЯДОЧИТЬ ПО
	|	Дата"; 	
	
	Если Объект.КоличествоОбрабатываемыхДокументов > 0 Тогда
		Запрос.Текст = СтрЗаменить(Запрос.Текст, "[ПЕРВЫЕ]" , "ПЕРВЫЕ " + Объект.КоличествоОбрабатываемыхДокументов);
	Иначе 
		Запрос.Текст = СтрЗаменить(Запрос.Текст, "[ПЕРВЫЕ]" , "");
	КонецЕсли;
	Выборка = Запрос.Выполнить().Выбрать();
	
	Пока Выборка.Следующий() Цикл
		НовДокумент = Объект.ДокументыЗаказыКлиентов.Добавить();
		НовДокумент.Пометка = Истина;
		НовДокумент.Дата = Выборка.Дата; 
		НовДокумент.Документ = Выборка.Ссылка; 
	КонецЦикла;
	
	Элементы.НайденоЗаказовКлиентов.Заголовок = "Найдено заказов клиентов: " + Выборка.Количество();
	
КонецПроцедуры

&НаКлиенте
Процедура НайтиЗаказыКлиентовСПустымНДС(Команда)
	
	НайтиЗаказыКлиентовСПустымНДСНаСервере();
	
КонецПроцедуры

&НаКлиенте
Процедура ДокументыЗаказыКлиентовВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
	
	Если Поле.Имя = "ДокументыЗаказыКлиентовДокумент" Тогда
		СтандартнаяОбработка = Ложь;
		ПоказатьЗначение(,Элемент.ТекущиеДанные.Документ);
	КонецЕсли;	
	
КонецПроцедуры

//-----------------*------------------//

 

Протестировано на платформе: 1С:Предприятие 8.3 (8.3.20.1674).

Протестировано в конфигурациях: 1С:Комплексная автоматизация 2 (2.5.7.402).

Скачать файлы

Наименование Файл Версия Размер
Перезаполнение Ставки НДС:

.epf 12,67Kb
0
.epf 12,67Kb Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Обнуление остатков и движений регистров накопления (УФ) Промо

Чистка данных Обработка документов Склад и ТМЦ v8 v8::УФ 1cv8.cf Россия УУ Абонемент ($m)

Универсальная обработка обнуления регистров накопления (остатки и обороты) для любой* конфигурации под управляемые формы.

4 стартмани

01.12.2017    13405    74    aleksch21    7    

Загрузка выписок из АЦК в формате XLT файлов для БГУ 2.0

Обработка документов Банковские операции Кассовые операции Бюджетный учет Файловые протоколы обмена (TXT, XML, DBF), FTP v8 v8::БУ БГУ Государственные, бюджетные структуры Россия БУ Госбюджет Абонемент ($m)

Обработка позволяет загружать из выписки лицевого счета в формате XLT (АЦК) в 1С: Бухгалтерию государственного учреждения 2.0 документы Кассовое поступление/выбытие.

1 стартмани

11.02.2022    3793    8    kirill1c    0    

Перепроведение документов с контролем проводок

Обработка документов v8 v8::БУ 1cv8.cf БУ Абонемент ($m)

Немного переделанная стандартная обработка «Проведение документов», контролирует проводки документов и если они изменились — сообщает об этом.

1 стартмани

05.06.2021    6219    8    AnryMc    0    

Связанные документы или Структура подчиненности (КА 2.4, ERP 2, УТ 11)

Обработка документов v8 ERP2 УТ11 КА2 УУ Абонемент ($m)

В форму структуры подчиненности документов добавлены кнопки проведения, отмены проведения и пометки на удаление. Также красным подсвечены поступления денег и синим списания.

1 стартмани

13.07.2020    16236    22    silver_jr    1    

Загрузка данных из Excel (из табличного документа) в часто используемые объекты: в справочники, документы, их табличные части, в планы видов расчетов, регистры расчета, регистры сведений Промо

Обработка документов Загрузка и выгрузка в Excel Обработка справочников v8 1cv8.cf Абонемент ($m)

Это перепиленная вдоль и поперек версия всем известной обработки "Загрузка из табличного документа" с диска ИТС. Добавлена возможность грузить в документы, виды расчетов, регистры расчета.

9 стартмани

25.06.2014    14810    30    Дмитрий74Чел    6    

"Учет штрафов ГИБДД" с возможной загрузкой из открытых источников в интернет Расширение конфигурации 1С: Предприятие 8.3

Обработка документов WEB v8 v8::УФ 1cv8.cf Россия БУ УУ Абонемент ($m)

Расширение конфигурации Бухгалтерия предприятия, редакция 3.0 (при минимальных изменениях любой типовой конфигурации), позволяющее вести историю данных по штрафам ГИБДД для справочника транспортных средств компании. Бонусом поставляется внешняя обработка, способная загружать эти данные из открытых источников в интернет.

4 стартмани

30.12.2019    24924    34    capitan    26    

Пакетное пробитие чеков на Онлайн-кассе при оплатах от физических лиц на расчетный счет

Банковские операции Кассовые операции Обработка документов v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Автоматизация процесса пробития чеков онлайн при поступлениях на расчетный счет от физических лиц. Помогает сократить трудозатраты таким организациям, как МФЦ, Управляющие компании и т.д. Подходит для 1С:Бухгалтерия 3.0 любой версии (базовая, ПРОФ, КОРП). Не изменяет конфигурацию. Конфигурация остается на поддержке (типовая).

2 стартмани

24.09.2019    27715    15    r.resh39    7    

Списание (корректировка) задолженности контрагентов УНФ 1.6

Взаиморасчеты Обработка документов Закрытие периода v8 УНФ Украина БУ Абонемент ($m)

Обнуление задолженности контрагентов в конфигурации "Управление небольшой (нашей) фирмой" версии 1.6 с помощью документа "Корректировка регистров".

1 стартмани

24.07.2019    37338    25    DMon    1    

Перенумерация документов для Бухгалтерии предприятия 3.0 Промо

Обработка документов v8 БП2.0 Россия Абонемент ($m)

Автоматическая перенумерация документов.

1 стартмани

11.11.2013    40955    1188    Poyarkov696    50    

Структура подчиненности с хронологией документов и кнопками проведения и удаления

Обработка документов v8 1cv8.cf Абонемент ($m)

Часто не хватает визуализации хронологии документов в структуре подчиненности и кнопок проведения. Это расширение конфигурации, с функционалом структуры подчиненности документов, отображающее хронологическую последовательность документов во времени и дающее доступ к проведению, отмене проведения, пометке на удаление документов непосредственно в форме подчиненности.

1 стартмани

22.07.2019    26986    105    sapervodichka    35    

Регистрация документов с измененной суммой

Обработка документов v8 1cv8.cf Абонемент ($m)

Обработка берет информацию из истории изменения документов. Удобна для администраторов, когда документы с измененной суммой по какой-то причине не регистрируются в плане обменов. Можно регистрировать не все документы, а только те, которые были изменены.

1 стартмани

20.04.2019    30790    9    ryan    0    

Валовая прибыль для УПП 1.3, КА 1.1 в режиме РАУЗ (работа типового отчета без доработок конфигурации)

Обработка документов v8 КА1 УПП1 УУ Абонемент ($m)

Простое и мгновенное решение для использования типового отчета "Валовая прибыль" в конфигурациях "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1" (а также отраслевых решений на их базе) при включенном режиме РАУЗ (расширенная аналитика учета затрат). Не требует настройки или изменения конфигурации, либо может быть, для дополнительного удобства, интегрировано в нее с минимальными доработками.

2 стартмани

21.01.2019    32528    41    stvorl    12    

Пометка на удаление неиспользуемых элементов справочников и документов Промо

Чистка данных Обработка документов Обработка справочников v8 v8::УФ 1cv8.cf Абонемент ($m)

В ходе работы в программе в ней зачастую накапливается "мусор". Данная разработка может помочь убрать его... (обычные или управляемые формы)

1 стартмани

02.02.2010    45510    738    AnryMc    53    

Универсальный инструмент для переноса данных через табличный документ (УФ)

Обработка документов Универсальные обработки Обработка справочников v8 v8::УФ 1cv8.cf Абонемент ($m)

Для опытных пользователей, разработчиков, администраторов, консультантов

5 стартмани

15.10.2018    52095    170    json    44    

Помощник корректировки остатков ЕГАИС в небольшом магазине. Розница 2.2

Розничная торговля Обработка документов v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Абонемент ($m)

Данная обработка упрощает корректировку остатков алкогольной продукции небольшого магазина, где предполагается передача всей продукции в торговый зал сразу после приемки.

5 стартмани

08.09.2018    49540    85    asdfgcom    47    

Расширение резервов отпусков

Обработка документов Зарплата v8 v8::СПР ERP2 ЗКГУ3.0 ЗУП3.x Россия БУ Абонемент ($m)

Произвольная настройка базы для расчета резервов отпусков.

2 стартмани

10.08.2018    42204    68    СергейКа    30    

Групповая установка даты выплаты в документах "Отпуск" и "Командировка" на заданную дату и перерасчет отобранных документов Промо

Обработка документов Зарплата v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

Обработка позволяет расчетчикам сократить время, затрачиваемое на расчет отпусков и командировок.

2 стартмани

15.02.2017    25931    92    ser6702    18    

Корректировка остатков ЕГАИС для 1С:Розница/УТ 10.3 - альтернативный вариант

Обработка документов Розничная торговля Склад и ТМЦ v8 Розница Розничная и сетевая торговля (FMCG) БУ Абонемент ($m)

Обработка корректировки остатков ЕГАИС для 1С Розница версии 2.2.7/2.2.8/2.2.9/2.2.10/2.2.11/УТ 10.3.47.ХХХ-48.XXX-49.XXX-50.XXX раздельно по маркируемому/немаркируемому алкоголю + создание документов постановки/списания по пересортице.

1 стартмани

02.06.2018    48399    441    independ    298    

Корректировка остатков ЕГАИС, возврат из регистра 2, загрузка ТТН из файлов, другое для УТ10.3

Розничная торговля Обработка документов v8 v8::ОУ УТ10 Россия БУ Абонемент ($m)

Набор обработок для автоматизации работы с ЕГАИС: Обработка корректировки остатков ЕГАИС для УТ 10.3, аналогичная имеющимся в УТ 11, Рознице 2.2. Автоматически формирует документы "Передача в торговый зал", "Акт постановки на баланс в торговом зале", "Акт списания в торговом зале". Обработка возврата из регистра 2 с подбором справок Б. Обработка формирования ТТН из файлов xml.

1 стартмани

24.01.2018    50948    20    biz-intel    6    

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника. ЗУП 3.1

Обработка документов Загрузка и выгрузка в Excel Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Абонемент ($m)

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника по данным экономического отдела. ЗУП 3.1.

3 стартмани

20.12.2017    67861    36    mvv1975    8    

[Расширение] Контроль отрицательных остатков по регистру бухгалтерии при проведении Промо

Склад и ТМЦ Обработка документов v8 1cv8.cf БУ Абонемент ($m)

Расширение позволяет без изменений конфигурации проверять остатки по регистру бухгалтерии при проведении каждого документа и запрещает проведение при появлении отрицательных остатков после проведения.

1 стартмани

17.08.2015    58538    171    ekaruk    33    

Копирование меню в Трактир Management

Обработка документов Производство готовой продукции (работ, услуг) v8 1cv8.cf Рестораны, кафе и фаст-фуд Россия УУ Абонемент ($m)

Механизм копирования меню в Трактир Management. Данная обработка расширяет функционал типового решения Трактир Management, позволяя быстро вводить в эксплуатацию новую точку путём создания нового меню на основании имеющегося.

1 стартмани

28.11.2017    40602    3    integrator1983    0    

Помощник по закрытию месяца для УТ 11.3

Обработка документов Закрытие периода v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Помощник по закрытию месяца для УТ 11.3. Имеет две функции: обнуление товаров "К оформлению" в интеркампани и обнуление отрицательных остатков в регистре "Себестоимость товаров".

5 стартмани

10.11.2017    36083    15    Zalipaka    1    

Упрощение работы с актами сверки в УТ/КА/УПП - вывод номеров счетов в документе и печатной форме

Обработка документов Печатные формы Взаиморасчеты v8 КА1 УТ10 УПП1 БУ УУ Абонемент ($m)

Обычно акт сверки с клиентами содержат информацию о документах реализации товаров (накладных) и выполненных платежах. Но платежи делаются на основании счетов, номера которых отсутствуют в актах, что затрудняет собственно сверку. Данная обработка находит соответствующие расходным накладным счета/заказы, показывает их в форме документа и выводит в печатную форму акта.

2 стартмани

12.05.2017    43374    4    denmax    7    

Загрузка из Excel-файла данных в документ Поступление товаров и услуг

Обработка документов Загрузка и выгрузка в Excel Оптовая торговля Розничная торговля Склад и ТМЦ v8 Розница БП3.0 УТ11 КА2 Россия БУ УУ Абонемент ($m)

Загрузка из произвольного Excel-файла документов Поступление товаров и услуг с возможностью создания номенклатуры, обработка позволяет автоматизировать процесс оформления новых поступлений товара.

1 стартмани

04.03.2017    44471    511    gzharkoj    138    

Редактор движений документа. Сохранение в XML, обмен между базами, замена регистратора.

Обработка документов Универсальные обработки Файловые протоколы обмена (TXT, XML, DBF), FTP v8 Абонемент ($m)

Редактор набора записей движений документа. Позволяет сохранить набор записей в XML, в настройки пользователя, прочитать сохраненный XML в другой идентичной базе, заменить регистратор. Можно изменять порядок записей, менять активность, как массово, так и по одной и др. Тонкий клиент, управляемые формы.

1 стартмани

07.09.2016    56081    174    Aphanas    5    

Загрузка Счета покупателя из PDF

Обработка документов Файловые протоколы обмена (TXT, XML, DBF), FTP Оптовая торговля v8 v8::БУ БП3.0 Абонемент ($m)

Обработка позволяет загрузить счет покупателя из pdf-файла в документ Счет на оплату покупателю (Бухгалтерия 3.0)

2 стартмани

23.05.2016    31578    31    John_d    5    

Обработка "Все одной кнопкой" (групповое создание и печать документов) для УПП ред. 1.3

Обработка документов Пакетная печать Кассовые операции Оптовая торговля Производство готовой продукции (работ, услуг) v8 УПП1 БУ УУ Абонемент ($m)

Данная обработка предназначена для группового создания, редактирования и печати основных документов («Реализация товаров и услуг», «Счет-Фактура выданный», «Счет на оплату клиентом», «Доверенность» на получение продукции, "Приходного кассового ордера") на основании документа «Заказ клиента». Основная цель обработки – оптимизация работы менеджеров при формировании пакета документов клиентам.

3 стартмани

09.04.2016    35468    36    SEOAngels    1    

Кнопка "Сообщить о проблеме". [Расширение]

Обработка документов v8 1cv8.cf Россия Абонемент ($m)

В документы добавлена кнопка "Сообщить о проблеме". По кнопке формируется письмо с технической информацией и ссылкой на объект. Остается только дописать, что не получилось, и можно отправлять письмо в техподдержку.

1 стартмани

31.03.2016    30152    75    mrXoxot    18    

Управление доставкой розничным покупателям

Обработка документов Розничная торговля v8 УТ10 Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Дополнение для УТ 11.1, оформление доставки для розничного покупателя на основании кассового чека в связке с мягким чеком покупателя.

5 стартмани

10.03.2016    39374    8    Denis_Viktorovich    5    

Ночное восстановление последовательности документов (фоновым заданием) для БП 3.0

Обработка документов v8 v8::БУ БП3.0 Россия Абонемент ($m)

Внешняя обработка служит для восстановления последовательности документов в БП 3.0 за месяц, по расписанию, фоновым заданием на сервере 1С. Подключается как дополнительная обработка в режиме пользователя.

10 стартмани

25.02.2016    47533    96    SmArtist    8    

Перечисление НДФЛ в бюджет РФ (13%, 30%)

Обработка документов Зарплата v8 v8::СПР ЗУП2.5 БУ НУ НДФЛ Абонемент ($m)

Внешняя обработка (табличных частей), предназначенная для корректного заполнения документа "Перечисление НДФЛ в бюджет РФ". Конфигурация: Зарплата и Управление Персоналом, редакция 2.5

1 стартмани

27.01.2016    46975    240    1kashak    23    

Начисление процентов по кредитам и займам для 1С:Бухгалтерии 3.0

Обработка документов Займы, кредит, лизинг v8 БП2.0 Россия БУ Абонемент ($m)

Универсальная обработка по начислению процентов по кредитам и займам для 1С:Бухгалтерии 3.0 без изменения конфигурации

1 стартмани

22.01.2016    79240    181    algora    27    

Пакетная замена номенклатуры с учетом характеристик

Обработка документов Оптовая торговля Склад и ТМЦ v8 КА1 УТ10 УПП1 УУ Абонемент ($m)

Обработка "Пакетная замена номенклатуры" в Заказе покупателя, Реализации и Поступлении товаров с использованием отбора по значениям характеристик

1 стартмани

22.01.2016    35046    5    trendy    1    

Формирование актов сверки взаиморасчётов и групповая печать

Обработка документов Пакетная печать Взаиморасчеты v8 БП2.0 БУ Абонемент ($m)

Обработка позволяет сформировать новые акты сверки и распечатать за период разом на принтере

3 стартмани

15.01.2016    45740    40    gortol    4    

Перечисление НДФЛ в бюджет: заполнение НДФЛ по расчетной ведомости для ЗУП 2.5

Обработка документов Зарплата v8 ЗУП2.5 Россия БУ НДФЛ Абонемент ($m)

Внешняя обработка для заполнению сумм НДФЛ для перечисления в бюджет по данным расчетной ведомости для 1С ЗУП 2.5

2 стартмани

30.12.2015    34204    71    pavel_pozdeev    4    

Акт сверки с номерами счетов-фактур, начальными остатками по договорам и заполнением по головному контрагенту [Расширение]

Обработка документов Взаиморасчеты v8 БП3.0 Россия БУ Абонемент ($m)

Акт сверки взаиморасчетов (БП 3.0): - Вывод начальных и конечных остатков по договорам в печатную форму; - Вывод валютной суммы для договоров в условных единицах; - Заполнение данных счетов-фактур или УПД; - Заполнение данных по головному контрагенту и всем обособленным подразделениям; - Заполнение представителя организации из ответственных лиц; - Факсимильная подпись и печать. Не требует снятия с поддержки и подходит для базовых конфигураций

1 стартмани

15.12.2015    70488    97    mrXoxot    40    

Резервы отпусков для УПП 1.3

Обработка документов Зарплата v8 УПП1 Россия БУ Абонемент ($m)

Обработка для создания резерва отпусков в 1С: УПП 1.3

1 стартмани

14.12.2015    40552    55    sarun    5    

Сброс неверной нумерации объектов

Обработка документов Обработка справочников v8 1cv8.cf Абонемент ($m)

Кратко о выправлении нумерации объектов

1 стартмани

07.11.2015    130670    1062    magobato    46    

Загрузка УПД в Бухгалтерию 3.0 из Excel

Обработка документов Загрузка и выгрузка в Excel Оптовая торговля v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Загрузка УПД из Excel в Бухгалтерию предприятия 3.0.96.30, с заведением номенклатуры в справочник , добавлением ГТД, стран происхождения.

2 стартмани

20.10.2015    33111    34    teyana    23    

Выгрузка и загрузка данных из файла Excel с поиском по любым полям (есть поиск по ссылке, всего три итерации поиска. Управляемые формы или "Такси")

Загрузка и выгрузка в Excel Обработка документов v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка позволяет загружать данные с поиском по ссылке как для загружаемого объекта, так и его свойств. Загружает справочники, документы, планы видов характеристик. Будет полезна как замена использования конвертации данных для задач переноса, а также как классическая загрузка из табличного документа (Excel). Поиск объекта при загрузке выполняется до трех раз с разными полями поиска (поля поиска настраиваются). Также реализована выгрузка в Excel по ссылкам. У обработки удобный интерфейс, в котором разберется даже начинающий пользователь. Загрузка накладных из файлов xls реализована с интеллектуальным поиском колонок с данными. В интеллектуальном поиске поддерживаются все основные типовые печатные формы.

5 стартмани

16.10.2015    72243    533    primat    35    

Прыг-Скок...или из MS EXCEL в 1С (8.2) (открытый код)

Обработка документов Обработка справочников Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Универсальная загрузка данных из Microsoft Office Excel. Автоматическая загрузка из любых по форме документов с очень удобным редактором. Почти готовый шаблон для любой конфигурации. Не требует регистрации-бесплатно.

1 стартмани

16.09.2015    78185    372    Tatitutu    50    

Перепроведение документа по части регистров

Обработка документов v8 1cv8.cf Абонемент ($m)

Обработка для перепроведения документов выбранного вида с частичным сохранением движений регистров и проводок.

1 стартмани

16.09.2015    31689    54    NILS2009    6