Программирование в Штрих-М Кассир 5

Публикация № 1208354

Разработка - Практика программирования

Штрих-М Кассир 5 программирование

Методы и свойства для программирования в Штрих-М Кассир 5.

15

 

Введение

Основная задача этого материала - это ознакомление с методиками программирования в программе Штрих-М Кассир 5.

 

Пред обработчики в Штрих-М Кассир 5

    1. Случаи применения

Пред обработчики сильнейший инструмент  - используются для того, чтобы обработать аргументы перед выполнением функции или дать функции свои аргументы для обработки, или пропустить выполнение функции при определенных условиях.

    1. Синтаксис для пред обработчиков

 

Для того чтобы пред обработчики стали работать, необходимо помещать обработки в каталог «ExtForms\ LogicalModules», наименование обработки не имеет никакого значения, расширения "epf".

Схематическое изображение обработки:

Обязательные реквизиты «Формы» в обработке, показаны ниже на рисунке:

 

Чтобы программа увидела ваш обработчик ее нужно инициализировать, рассмотрим на примере функции «Функция ЗакрытьЧек(Отмена = 0) Экспорт»  из обработки «Регистрация»:

Процедура ИнициализироватьМодуль() экспорт

       Если Метаданные.Имя = "ШтрихМ_Кассир" Тогда                                 

              МенеджерОбъектов.ПолучитьОбщийОбъект("LogicalModules").НазначитьОбработчик("Регистрация.ЗакрытьЧек.ПредОбработка", ЭтаФорма, Неопределено);

       КонецЕсли;

КонецПроцедуры

и соответственно при завершении работы кассира деинициализировать:

Процедура ДеИнициализироватьМодуль() экспорт

       Если Метаданные.Имя = " ШтрихМ_Кассир " Тогда

              МенеджерОбъектов.ПолучитьОбщийОбъект("LogicalModules").СнятьОбработчик("Регистрация.ЗакрытьЧек.ПредОбработка", ЭтаФорма, Неопределено);

       КонецЕсли;

КонецПроцедуры

Причем  Метаданные.Имя обязательно должны быть сравнимы с именем «ШтрихМ_Кассир», иначе программа не инициализирует вашу доработку.

И наконец вызов самой функции:

Функция Регистрация_ЗакрытьЧек_ПредОбработка(Отмена) Экспорт

       Обработчик = МенеджерОбъектов.ПолучитьОбщийОбъект("LogicalModules").ПолучитьОбработчик("Регистрация.ЗакрытьЧек.ПредОбработка", _Источник, ЭтаФорма);

       Если Обработчик <> Неопределено Тогда

                      _РезультатВызова =

                      Обработчик.Регистрация_ЗакрытьЧек_ПредОбработка(Отмена);

                      Если Обработчик._Отказ Тогда

                                      Возврат _РезультатВызова;

                      КонецЕсли;

       КонецЕсли;

…

КонецФункции

1-я часть шапка самой функции, она является вызовом с главной функции, затем идет тело функции, здесь код программиста, и конец возврат какого значения или же ничего.

Если присвоить переменной «Обработчик._Отказ»  истину, в этом случае функция в основном теле программы после обработчика выйдет из функции, т.е. пропустит ее выполнение.

 

    1. Доступ к основной форме (источник)

 

Иногда необходимо обратиться к некоторым методам чтобы узнать или изменить что-либо на форме или в содержании программы, для этого есть возможность обратиться к функциям основной программы, если они имеют реквизит «Экспорт», Примеры:

_Источник.ФункцияФормыРегистрации_Вниз()

– спускает курсор вниз по табличному полю

_Источник.ФункцияФормыРегистрации_ПросмотрПечатьЧека()

– просмотр и печать закрытого чека

 

Обращение к переменным основной программы, примеры:

_Источник. ГлавноеПолеВвода 

Значение главного поля ввода

_Источник.СоставЧека

– Состав чека в виде табличного значения

 

    1. Способы передачи данных

 

Между обработок необходимо передавать данные, один из универсальных способов это сохранять данные в текстовый файл, а затем его считывание, пример:

Сохранение данных-

ИмяФайла = Кассир5_DataAccess.КаталогВнешнихКомпонент + "data.ini";

ЗначениеВФайл(ИмяФайла,ПАР);

ПАР – это переменная или структура данных

 

Загрузка данных-    

Перем ПАР;

       ПАР = Новый Структура;

       ПАР.Вставить("Имя1");

      …

       ПАР.Вставить("ИмяN");



       //Считать из файла

       ИмяФайла = Кассир5_DataAccess.КаталогВнешнихКомпонент + "data.ini";

       Файл = Новый Файл(ИмяФайла);

       Если Файл.Существует() Тогда

                      ФайлЗагрузки = Новый ТекстовыйДокумент();

                      Попытка

                                      ФайлЗагрузки.Прочитать(ИмяФайла, КодировкаТекста.ANSI);

                                      ФайлЗагрузки = Неопределено;

                      Исключение

                                      Возврат ПАР;

                      КонецПопытки;

                     

                      ПолученноеЗначение = ЗначениеИзФайла(ИмяФайла);

                      Для каждого эл из ПолученноеЗначение Цикл

                                      Попытка

                                                      ПАР[эл.Ключ] = эл.Значение;

                                      Исключение

                                      КонецПопытки;               

                      КонецЦикла;      

                      Возврат ПАР;

       КонецЕсли;

       Возврат ПАР;

 

Еще один метод, расположить все функции в одной обработке, а переменные сохранять на форме.

 

    1. Пример
Процедура ДеИнициализироватьМодуль() экспорт

       Если Метаданные.Имя = "ШтрихМ_Кассир" Тогда

              МенеджерОбъектов.ПолучитьОбщийОбъект("LogicalModules").СнятьОбработчик("Регистрация.ФункцияФормыРегистрации_ПродолжитьОтложенныйЧек.ПредОбработка", ЭтаФорма, Неопределено);

       КонецЕсли;

КонецПроцедуры// ДеИнициализироватьМодуль()



Процедура ИнициализироватьМодуль() экспорт

       Если Метаданные.Имя = "ШтрихМ_Кассир" Тогда                                 

              МенеджерОбъектов.ПолучитьОбщийОбъект("LogicalModules").НазначитьОбработчик("Регистрация.ФункцияФормыРегистрации_ПродолжитьОтложенныйЧек.ПредОбработка", ЭтаФорма, Неопределено);

       КонецЕсли;

КонецПроцедуры // ИнициализироватьМодуль()



Функция Регистрация_ФункцияФормыРегистрации_ПродолжитьОтложенныйЧек_ПредОбработка() Экспорт

       Обработчик = МенеджерОбъектов.ПолучитьОбщийОбъект("LogicalModules").ПолучитьОбработчик("Регистрация.ФункцияФормыРегистрации_ПродолжитьОтложенныйЧек.ПредОбработка", _Источник, ЭтаФорма);

       Если Обработчик <> Неопределено Тогда

                      Обработчик.Регистрация_ФункцияФормыРегистрации_ПродолжитьОтложенныйЧек_ПредОбработка();

       КонецЕсли;      

      

       Если ВыполнитьВнешнююОбработку("ОбщиеФункции","Константы_РежимПАЕ_Получить") Тогда

                      //И если карта на приборе тогда ф-ция запрещена

                      ЭтаФорма._Отказ = Истина;

                      Возврат Истина;

       КонецЕсли;

      

КонецФункции

 

Пост обработчики в Штрих-М Кассир 5

    1. Случаи применения

Пост  обработчики, аналогичен инструменту пред обработчиков, только используются после выполнения функции.

    1. Синтаксис для пост обработчиков

 

Для того чтобы пред обработчики работали необходимо помещать обработки в каталог «ExtForms\ LogicalModules», наименование обработки не имеет никакого значения.

Схематическое изображение обработки:

Обязательные реквизиты «Формы» в обработке, показаны ниже на рисунке:

 

Чтобы программа увидела ваш обработчик ее нужно инициализировать, рассмотрим на примере функции «Функция ЗакрытьЧек(Отмена = 0) Экспорт»  из обработки «Регистрация»:

Процедура ИнициализироватьМодуль() экспорт

       Если Метаданные.Имя = "ШтрихМ_Кассир" Тогда                                 

              МенеджерОбъектов.ПолучитьОбщийОбъект("LogicalModules").НазначитьОбработчик("МодульПриложения.ПриНачалеРаботыСистемы.ПостОбработка", ЭтаФорма, Неопределено);

       КонецЕсли;

КонецПроцедуры

 

 и соответственно при завершении работы кассира деинициализировать:

Процедура ДеИнициализироватьМодуль() экспорт

       Если Метаданные.Имя = "ШтрихМ_Кассир" Тогда

       МенеджерОбъектов.ПолучитьОбщийОбъект("LogicalModules").СнятьОбработчик("МодульПриложения.ПриНачалеРаботыСистемы.ПостОбработка", ЭтаФорма, Неопределено);

       КонецЕсли;

КонецПроцедуры

 

Причем  Метаданные.Имя обязательно должны быть сравнимы с именем «ШтрихМ_Кассир», иначе программа не инициализирует вашу доработку.

И наконец вызов самой функции:

Функция ПриНачалеРаботыСистемы_ПостОбработка() Экспорт

      

       Обработчик = МенеджерОбъектов.ПолучитьОбщийОбъект("LogicalModules").ПолучитьОбработчик("МодульПриложения.ПриНачалеРаботыСистемы.ПостОбработка", _Источник, ЭтаФорма);

       Если Обработчик <> Неопределено Тогда

                      Обработчик.ПриНачалеРаботыСистемы_ПостОбработка();

       КонецЕсли;

…

КонецФункции

 

1-я часть шапка самой функции, она является вызовом с главной функции, затем идет тело функции, здесь код программиста, и конец возврат какого значения или же ничего.

 

    1. Доступ к основной форме (источник)

 

Иногда необходимо обратиться к некоторым методам чтобы узнать или изменить что-либо на форме или в содержании программы, для этого есть возможность обратиться к функциям основной программы, если они имеют реквизит «Экспорт», Примеры:

_Источник.ФункцияФормыРегистрации_Вниз() 

– спускает курсор вниз по табличному полю

_Источник.ФункцияФормыРегистрации_ПросмотрПечатьЧека()

– просмотр и печать закрытого чека

 

Обращение к переменным основной программы, примеры:

_Источник. ГлавноеПолеВвода

Значение главного поля ввода

_Источник.СоставЧека

– Состав чека в виде табличного значения

 

    1. Способы передачи данных

 

Между обработок необходимо передавать данные, один из универсальных способов это сохранять данные в текстовый файл, а затем его считывание, пример:

Сохранение данных-

ИмяФайла = Кассир5_DataAccess.КаталогВнешнихКомпонент + "data.ini";

ЗначениеВФайл(ИмяФайла,ПАР);

ПАР – это переменная или структура данных

 

Загрузка данных-    

Перем ПАР;

       ПАР = Новый Структура;

       ПАР.Вставить("Имя1");

      …

       ПАР.Вставить("ИмяN");



       //Считать из файла

       ИмяФайла = Кассир5_DataAccess.КаталогВнешнихКомпонент + "data.ini";

       Файл = Новый Файл(ИмяФайла);

       Если Файл.Существует() Тогда

                      ФайлЗагрузки = Новый ТекстовыйДокумент();

                      Попытка

                                      ФайлЗагрузки.Прочитать(ИмяФайла, КодировкаТекста.ANSI);

                                      ФайлЗагрузки = Неопределено;

                      Исключение

                                      Возврат ПАР;

                      КонецПопытки;

                     

                      ПолученноеЗначение = ЗначениеИзФайла(ИмяФайла);

                      Для каждого эл из ПолученноеЗначение Цикл

                                      Попытка

                                                      ПАР[эл.Ключ] = эл.Значение;

                                      Исключение

                                      КонецПопытки;               

                      КонецЦикла;      

                      Возврат ПАР;

       КонецЕсли;

       Возврат ПАР;

 

Еще один метод, расположить все функции в одной обработке, а переменные сохранять на форме.

 

    1. Пример
Процедура ДеИнициализироватьМодуль() экспорт

       Если Метаданные.Имя = "ШтрихМ_Кассир" Тогда

              МенеджерОбъектов.ПолучитьОбщийОбъект("LogicalModules").СнятьОбработчик("Регистрация.ЗакрытьЧек.ПостОбработка", ЭтаФорма, Неопределено);

       КонецЕсли;

КонецПроцедуры// ДеИнициализироватьМодуль()



Процедура ИнициализироватьМодуль() экспорт

       Если Метаданные.Имя = " ШтрихМ_Кассир " Тогда                                 

              МенеджерОбъектов.ПолучитьОбщийОбъект("LogicalModules").НазначитьОбработчик("Регистрация.ЗакрытьЧек.ПостОбработка", ЭтаФорма, Неопределено);

       КонецЕсли;

КонецПроцедуры // ИнициализироватьМодуль()



Функция Регистрация_ЗакрытьЧек_ПостОбработка(Отмена) Экспорт

       Обработчик = МенеджерОбъектов.ПолучитьОбщийОбъект("LogicalModules").ПолучитьОбработчик("Регистрация.ЗакрытьЧек.ПостОбработка", _Источник,ЭтаФорма);

       Если Обработчик <> Неопределено Тогда

                      //Обработчик._РезультатВызова = внРезультат;

                      _РезультатВызова =

                      Обработчик.Регистрация_ЗакрытьЧек_ПостОбработка(Отмена);

                      Если Обработчик._Отказ Тогда

                                      Возврат _РезультатВызова;

                      КонецЕсли;

       КонецЕсли;

***              

КонецФункции

 

 

 

Добавление кнопок в меню «Супервизор»

    1. Случаи применения

В некоторых случаях необходимо получить какой-то отчет, отправить на печать что-либо или же задать свои константы. Для этого есть технология добавления копок в меню «Супервизора».

    1. Как использовать, синтаксис содержимого

Во первых в папке ExtFiles создать файл «s_visor.ini», примерное содержимое:

[общие]

имя кнопки=Выгрузка Тов

[Настройка выгрузки]

функция=Data/btn1.1s

И выглядеть это будет так, для строки «имя кнопки=Выгрузка Тов» :

для строки «[Настройка выгрузки]» :

для строки «функция=Data/btn1.1s» :

Затем в папке «ExtForms» создадим каталог «Data» со следующим содержимым:

Содержимое файла btn1.1s

МодульОбмена = ВнешниеОбработки.Создать(Кассир5_DataAccess.КаталогВнешнихКомпонент + "Data\МодульСервиса.epf");

Если МодульОбмена <> Неопределено Тогда

                АктивнаяФорма = Неопределено;

                МодульОбмена.ПолучитьФорму("ФормаНастройки").ОткрытьМодально();

                АктивнаяФорма = ЭтаФорма;

КонецЕсли;

Обработка «МодульСервиса.epf», ее архитектура

Внутреннее содержимое Формы может быть любым, по нажатию кнопки можно выполнять любую функцию.

 

Добавление кнопки на форму регистрации и привязка функции к ней

    1. Случаи применения

В некоторых случаях необходимо  в режиме регистрации иметь функционал, который отсутствует в данной версии.

    1. Как расположить и синтаксис функции

Зайдем в Кассир 5 под правами администратора, в меню «Супервизора» перейдем в «Настройка»:

Затем в «Настройка формы регистрации»

Затем нажмем кнопку «>>»

В появившемся окне, добавим кнопку   правой кнопкой мыши «добавить кнопку», например «сертификат»

На добавленной кнопке нажмем правой кнопкой мыши «изменить», выбираем функцию

Сперва ее создадим, 

Заполним внутреннее содержимое, в данном случае это функция из обработки регистрация:

После сохранения функции, подключим функцию к кнопке, т.е. подключим.

Затем нажмем выход, «Esc»   и нажмем «Да», т.е. сохранить настройки.

    1. Редактирование и создание кнопок

Кнопки можно создавать через редакторы BMP или PNG и затем в настройке заходить в «Кнопки»

Через кнопку вставки добавлять кнопку или же ее изменять

Обязательно запомнить ее имя, а также заполнить значения картинок

На примере кнопки «Пром итог», нужно заполнить те расширения, в которых будет использоваться ваша кнопка, также это сделать для вариантов «Картинка нажатая», «Картинка недоступная», «Картинка активная»

 

 

Описание каталогов в папке «ExtForms»

В папке «ExtForms» есть следующие каталоги, см.ниже:

Каталог «AddOutputDev» - работа с дисплеями

Каталог «DataExchange» - загрузка и выгрузка файлов

Каталог «DCTerminals» - работа с терминалами данных

Каталог «Documents» - работа с документами

Каталог «Egais» - работа с ЕГАИС

Каталог «ExternalDB» - работа с базы данными(DBF, SQL)

Каталог «FPrinters» - работа с принтерами(ФР)

Каталог «LblComplex» - работа с весами, в которые можно загрузить товары.

Каталог «LogicalModules» - работа с дополнительными обработками

Каталог «Reports» - работа с отчетами

Каталог «Scales» - работа с весами

Каталог «Scanners» - работа с весами

Каталог «ShtrihPayMan.Modules» - работа с менеджером оплат

Каталог «Update» - работа с обновлением

Каталог «VideoControl» - работа с видео объектами наподобие кэшконтрола.

Данные каталоги имеют содержимое в виде обработок, так что у любого программиста 1С есть возможность изменить код.

 

Изменения самой конфигурации Штрих-М Кассир 5

Если вы купили типовую конфигурацию Штрих-М Кассир-5, есть возможность ее редактирования, единственное что при обновлении вам придется переносить ваши доработки, причем возможно что некоторые придется еще переписывать.

 

Заключение.

Из рассмотренных методов большая гибкость, она заключается в возможности создавать свою библиотеку и использовать по всем своим кассовым местам, с возможностью быстрого обновления.

Изменения интерфейса, изменения функционала – это сила данного метода.

В случае изменения основной конфигурации, возможно придется переписывать готовые библиотеки обработок, это один возможных минусов.

 

Дополнительные ресурсы:

https://kkm.solutions/wiki/doku.php?id=кассир5:руководствопрограммиста

https://kkm.solutions/produkty/roznichnaya-torgovlya/shtrikh_m_kassir_5_0/

https://www.shtrih-m.ru/catalog/avtomatizatsiya-torgovli/shtrikh-m-kassir-5/

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. Van2507 5 18.03.20 15:40 Сейчас в теме
Интересная статья. Есть один вопрос. При заполнении содержимого функции на добавленной кнопки можно использовать только уже имеющиеся функции в конфигурации, точнее можно ли написать свою функцию в этом окне, или нужно указывать именно ссылку на функцию?
2. Ignatov_mu 30 24.03.20 23:09 Сейчас в теме
Можно описать полностью свою функцию.
Оставьте свое сообщение

См. также

3 онлайн-курса по 1С-программированию: обмен данными, расчетные задачи и бухгалтерские задачи с 12 мая по 8 июля 2020 г. Промо

Практика программирования v8 Бесплатно (free)

Пакет из 3-х курсов по 1С-программированию. Основная цель - сформировать у слушателей практические навыки, связанные с реализацией задач обмена для прикладных решений, работающих на платформе “1С:Предприятие”, а также с разработкой прикладных решений, предназначенных для автоматизации расчета заработной платы и задач бухгалтерского учета.

22.04.2020    3325    23    infostart    2    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    15438    0    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    15911    0    John_d    22    

Последовательности событий. Шпаргалка

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    11032    0    kuzyara    33    

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    34305    0    unichkin    45    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    12838    0    YPermitin    72    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    25651    0    Yashazz    45    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    35228    0    rpgshnik    62    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    26330    0    tormozit    100    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    37387    0    ids79    52    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    21907    0    YPermitin    24    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    21955    0    YPermitin    80    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    73822    0    tormozit    129    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    25896    0    ids79    16    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    56940    0    ids79    37    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    26661    0    avalakh    21    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    44876    0    tormozit    38    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    43151    0    ids79    11    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    28807    0    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    21674    0    YPermitin    13    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    40696    0    tormozit    72    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    16528    0    SeiOkami    50    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    42601    0    ids79    20    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    21545    0    dmurk    144    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    14248    0    m-rv    2    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    35598    0    YPermitin    30    

Выполнение внешней обработки в фоновом задании

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    24405    0    Eret1k    23    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    29585    0    ellavs    126    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    17844    0    m-rv    17    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    23572    0    ellavs    86    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    26664    0    YPermitin    53    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    18536    0    Vladimir Litvinenko    27    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    27521    0    m-rv    21    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    31728    0    ids79    9    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    22977    0    ids79    31    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    25808    0    itriot11    34    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    35301    0    ids79    72    

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Практика программирования Обмен через XML v8 v8::УФ БП3.0 УТ11 Россия Бесплатно (free)

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    31974    0    ids79    32    

Программное заполнение пользовательских параметров и отборов СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    37879    0    Unk92    21    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    71299    0    Serginio    108    

Произвольный код в фоновом режиме

Практика программирования v8 1cv8.cf Бесплатно (free)

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    24094    0    nikita0832    42    

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C

Математика и алгоритмы Практика программирования v8 Россия Бесплатно (free)

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    35013    0    Rain88    46    

Работаем с дополнительными реквизитами на форме

Практика программирования v8 Бесплатно (free)

Пара полезных процедур для работы с дополнительными реквизитами на форме. Далее в статье: 1. Как называются дополнительные реквизиты на форме и в какой момент они появляются на форме? 2. Как проверить до записи корректность заполнения пользователем дополнительного реквизита? 3. Как заполнить значение дополнительного реквизита по другому событию и обновить данные на форме? 4. Как расположить дополнительный реквизит в указанном месте на форме?

15.07.2018    29674    0    papche    37    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    30760    0    ids79    40    

Повышаем эффективность разработки правил обмена

Практика программирования Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    26232    0    olegtymko    47    

Введение в механизм представлений в ЗУП ред. 3

Практика программирования v8 v8::СПР ЗУП3.x Бесплатно (free)

В нашей организации на первом же телефонном собеседовании на должность разработчика по ЗУП ред. 3 вас обязательно спросят о том, что такое "Представления".

04.06.2018    34362    0    xrrg    82    

Строим графы средствами 1С (без GraphViz)

Практика программирования v8 Бесплатно (free)

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    22932    0    slozhenikin_com    20    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    26363    0    grumagargler    26    

Распределение расходов пропорционально продажам

Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Практика программирования Финансовый учет и бюджетирование (FRP) Учет доходов и расходов v8 v8::ОУ УТ10 УУ Бесплатно (free)

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    17061    0    Rustig    9    

Просмотр временных таблиц запроса в отладчике без изменения кода

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

Данный способ можно использовать для просмотра содержимого временных таблиц запросов (менеджеров временных таблиц) без внесения изменений в код.

24.04.2018    43233    0    avfed@rambler.ru    26    

[ВсеПросто] "Оперативный" информатор из 1С за 5 мин.

Практика программирования v8 Бесплатно (free)

Быть всегда в курсе дел, даже в дороге!

22.02.2018    25374    0    DarkAn    25    

Минимализмы 3

Практика программирования Универсальные функции v8 Бесплатно (free)

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    43964    0    ildarovich    45